Erlo

nodejs支持import吗

收藏 2021-11-05 17:00:14   225   php中文网
页面报错/反馈
点赞

nodejs不支持import语句,原因:nodejs采用的是CommonJS的模块化规范,使用require语句引入模块;而import是ES6的模块化规范关键字。

本教程操作环境:windows7系统、nodejs 12.19.0版,DELL G3电脑。

nodejs不支持import语句。

原因:nodejs采用的是CommonJS的模块化规范,使用require引入模块;而import是ES6的模块化规范关键字。

而有时又需要使用import,要怎么做?

想要使用import,必须引入babel转义支持,通过babel进行编译,使其变成node的模块化代码。

在node中使用import/export的方法:

想要使用import,必须引入babel转义支持,通过babel进行编译,使其变成node的模块化代码。

我们可以在命令行中使用

babel-node 命令来进行编译,babel-node 命令不是独立安装,在 Babel 7.X 版本前,需要通过安装 babel-cli

包获得;在 Babel 7.X 版本,需要安装 @babel/core、@babel/cli 两个包。

说明:此处以 7.X 之前的版本举例,7.X 版本可去官网查找对应包的使用用例

安装必要的插件

全局安装babel-cli

npm install babel-cli -g

安装 babel-preset-env

npm install babel-preset-env -D

然后原来是node server.js,改为这样调用:babel-node --presets env server.js

需要注意的是如果只是为了 babel-node 这一个命令,安装 babel-cli 会加载安装很多资源和模块,出于性能考虑不推荐在生产环境使用。自己在开发调试的时候,可以鼓捣着玩玩

【推荐学习:《nodejs 教程》】

登录查看全部

参与评论

评论留言

还没有评论留言,赶紧来抢楼吧~~

返回顶部

给这篇文章打个标签吧~

棒极了 糟糕透顶 好文章 PHP JAVA JS 小程序 Python SEO MySql 确认