Erlo

关于Unsupported major.minor version 52.0解决办法(再次回顾)

时间:2019-04-15   阅读:260次   来源:博客园
页面报错
点赞

对于web项目的配置问题,在很大程度上,tomcat的版本问题起到很大的决定性因素,例如以上问题:Unsupported major.minor version 52.0 表示stanford parser和jdk版本不对应,即 你项目用JDK1.8运行过,现在又在本地的eclipse等开发工具或者本地环境变量为低版本的jdk1.7或者jdk1.6下运行,eclipse会说:“本地jdk版本太低,不支持这个jdk1.8编译过的项目运行”。

对应关系如下:

  J2SE 8 = 52,J2SE 7 = 51,

  J2SE 6.0 = 50, J2SE 5.0 = 49,

  JDK 1.4 = 48, JDK 1.3 = 47,

  JDK 1.2 = 46, JDK 1.1 = 45

通过后边的数字我们可以很容易的判断当前应该使用哪一个版本。

在52版本一下,直接选择对应的tomcat即可,如果要使用tomcat8.5,则需要按照以下步骤对tomcat进行配置:

  1. 打开tomcat的lib目录。C:apache-tomcat-8.5.24lib,选择catalina.jar文件已压缩包的形式打开

     

  2.  

    根据路径找到文件:orgapachecatalinautil 的ServerInfo.properties  以记事本格式打开

  3.  

    修改为:

    当前内容

  4.  

    点击 “确定”,进行保存

  5.  

    需要下载eclipse的补丁:bugs.eclipse.org/bugs/attachment.cgi?id=262418&action=edit 打开eclipse安装路径,放入plugins文件夹中。这样就结束了,不需要重启eclipse

    eclipse配置tomcat8.5(注意是8.5)

     

     

    操作成功!

        

 根据:https://jingyan.baidu.com/article/48a42057f8dfafa92525044d.html

 

提交留言

评论留言

还没有评论留言,赶紧来抢楼吧~~

吐槽小黑屋()

* 这里是“吐槽小黑屋”,所有人可看,只保留当天信息。

  • Erlo吐槽

    Erlo.vip2021-07-29 12:36:43Hello、欢迎使用吐槽小黑屋,这就是个吐槽的地方。
  • 返回顶部

    给这篇文章打个标签吧~

    棒极了 糟糕透顶 好文章 PHP JAVA JS 小程序 Python SEO MySql 确认