Erlo

MyEclipse mac版删除代码崩溃

时间:2018-05-02   阅读:3186次   来源:博客园
页面报错
点赞

Mac升级了系统到 High Sierra但MyEclipse却没更新(一般用PO JIE),这总情况的MyEclipse在一些特定的正常操作中总会强行崩溃

极大的影响的Mac程序员的编码,面对这种问题我在各大论坛看过几种解答,总结一下:

  1.电脑版本降级(High Sierra 以前的版本,升级系统花了那么长时间,装B利器降级?能忍吗?反正我不能忍)

  2.买正版,升级(吐嚎参考)

以上是最多的回答,下面重点来了,经过一段时间的MyEclipse官网观察,一个小意外,发现了手动装插件修改MyEclipse

原网址:请点击我,安全,无毒,绿色

网站是英文,有兴趣的小伙伴可以点进去了.

中文解释 :    

  1.彻底关闭myeclipse

  2.找到plugins文件夹中的org.eclipse.swt.cocoa.macosx.x86_64_3.105.1.v20160907-0248.jar文件(这个文件只有在myeclipse 2017 CI.myeclipse 2017 Stable才有),先备份到你喜欢的文件夹,删掉原文件

(对着myeclipse右击显示包内容找到Contents/Profile/plugins)

  3.下载 fix-502711.zip 解压到plugins文件夹中

  4.编辑 eclipse.ini 增加一行 -clean (其他的别动,我的这个文件在Contents/Profile/) 前4行如下后面 别动 别动 别动 

#ansi (do not remove)
-clean
-startup
../Profile/plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
…

  5.现在运行你的myeclipse

以上~大功告成!

评论留言

还没有评论留言,赶紧来抢楼吧~~

吐槽小黑屋()

* 这里是“吐槽小黑屋”,所有人可看,只保留当天信息。

  • Erlo吐槽

    Erlo.vip2021-06-23 03:20:34Hello、欢迎使用吐槽小黑屋,这就是个吐槽的地方。
  • 返回顶部

    给这篇文章打个标签吧~

    棒极了 糟糕透顶 好文章 PHP JAVA JS 小程序 Python SEO MySql 确认