Erlo

vue项目中兼容ie8以上浏览器的配置

时间:2019-07-31 12:04   阅读:93次   来源:博客园页面报错

点赞

1.首先需要在根目录的index.html文件加入如下代码

<meta http-equiv="X-UA-Compatible" content="IE=edge">

2.npm安装依赖

安装babel-polyfill 插件

指令:
npm install babel-polyfill --save-dev

3.在入口文件main.js文件中引入插件

import 'babel-polyfill'

4.需要在webpack.base.config.js配置文件中做如下修改

module.exports = { 
entry: { 
app: ["babel-polyfill", "./src/main.js"] 
} 
}; 
替代 
module.exports = { 
entry: { 
app: './src/main.js' 
} 
} 

到此就配置完成了

下一篇:vue history模式下,部署到服务器 出现空白页情...

评论留言

还没有评论留言,赶紧来抢楼吧~~

Erlo大厅()

* 这里是“吐槽厅”,所有人可看,只保留当天信息。

  • Erlo.vip2019-09-19 11:01:26Hello、欢迎使用吐槽厅,这里是个吐槽的地方。
  • 首页 笔记分享 案例展示 ERLO 搜索
    鼠标试试
    返回顶部